Gimp asennusongelma


#1

Yritin asenaa mint 19.1:een Gimpiä. Sain seuraavan ilmoituksen

Halunnet suorittaa “apt --fix-broken install” korjaamaan nämä.
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
gimp-gmic : Riippuvuudet: libgimp2.0 (>= 2.10.8+om-0ubu18.04.3~ppa) mutta 2.8.22-1 on merkitty asennettavaksi
E: Kaikkia riippuvuuksia ei ole tyydytetty. Kokeile “apt --fix-broken install” ilmanpaketteja (tai ratkaise itse).

En osaa korjata ongelmaa!!

Tämä ongelma aiheuttaa myös etten saa poistettua GIMPiä

Onko tietoa josta olisi apua?

Kitos


#2

suorita päätteessä:
sudo apt --fix-broken install

… kuten virheilmoituksessa ehdotetaan.


#3

Rikkinäiset paketit tekevät näin.


#4

Epävirallisten PPA-repojen käyttö voi hyvinkin johtaa ristiriitoihin. Todennäköisesti pystyt poistelemaan kyllä Gimp:iin asentamiasi toimimattomia osia yksi kerrallaan. (Jos tuo fix-broken ei jo ratkaise pahinta ongelmaa, ja estä lopulta poistamasta jakeluun virallisesti kuulumatonta versiota Gimp:stä. ) Asenna lopulta virallinen jakeluversion Gimp-versio.