Archbang ja 1440x900 resoluutio

Latailin kakkoskoneeseen archbangia ja vastaan tuli suuri ongelma. Asennuksen jälkeen näyttöni resoluutio oli 1024x768. Heitin komentoriville “xrandr -s 1440x900” sain vastaukseksi “Size 1440x900 not found in available modes.” xorg.conffi näyttää tältä:

Section "ServerLayout" Identifier "X.org Configured" Screen 0 "Screen0" 0 0 InputDevice "Mouse0" "CorePointer" InputDevice "Keyboard0" "CoreKeyboard" EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "dbe"
Load "dri"
Load "dri2"
Load "extmod"
Load "glx"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option “Protocol” "auto"
Option “Device” "/dev/input/mice"
Option “ZAxisMapping” "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section “Device”
### Available Driver options are:-
### Values: : integer, : float, : “True”/“False”,
### : “String”, : " Hz/kHz/MHz",
### : “%”
### [arg]: arg optional
#Option “ShadowFB” # []
#Option “DefaultRefresh” # []
#Option “ModeSetClearScreen” # []
Identifier "Card0"
Driver "vesa"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Modes “800x600” “1024x768” "1440x900"
EndSubSection
EndSection

Koneen (taikka äxän) uudelleenkäynnistäminen ei auta. 800x600 ja 1024x768 toimii. Missä vika?

PS: Tuo kone siis läppäri, Acer Aspire 7720Z 17".

Vika on siinä, että käytät vesa-ajuria, joka ei tue laajakuvaresoluutioita. Oletko varma, että tarvitset xorg.conf-tiedostoa ollenkaan? Nykyiset xorg-versiot osaa yleensä konffata itse itsensä ilman sitä.

Eli mitä minun pitäisi suomeksi tehdä?

[quote=“BloodyRevolution, post:3, topic:1207”][quote author=vpv link=topic=1531.msg7223#msg7223 date=1292008884]
Vika on siinä, että käytät vesa-ajuria, joka ei tue laajakuvaresoluutioita. Oletko varma, että tarvitset xorg.conf-tiedostoa ollenkaan? Nykyiset xorg-versiot osaa yleensä konffata itse itsensä ilman sitä.
[/quote]

Eli mitä minun pitäisi suomeksi tehdä?[/quote]

Nimeä se xorg.conf uudelleen ja kokeile. :slight_smile: Esim. näin (tosin oletan, että osaa kerta Archin ole asentanut, paitsi jos Archbang != Arch ::)):

su - mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old exit

[quote=“Tomin, post:4, topic:1207”][quote author=BloodyRevolution link=topic=1531.msg7226#msg7226 date=1292094729]

Eli mitä minun pitäisi suomeksi tehdä?
[/quote]

Nimeä se xorg.conf uudelleen ja kokeile. :slight_smile: Esim. näin (tosin oletan, että osaa kerta Archin ole asentanut, paitsi jos Archbang != Arch ::)):

su - mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old exit[/quote]

Ei auta. Nimesin tiedoston uudelleen ja reboottasin, mutta ei auttanut. Mitä tehdä?

Lue xorgin lokit läpi (Fedorassa ainakin /var/log/Xorg.0.log) ja katso, mitä ajuria se käyttää ja millaista näyttötilaa se yrittää asettaa. Koneessa taitaa olla Intelin näytönohjain, tarkista, että xf86-video-intel on asennettuna, millä nimellä se nyt sitten sattuukaan olemaan paketoituna. Tosiaan, Archbangin kanssa saattaa tarvita vähän ylimääräistä säätöä, Arch itse ei ainakaan ole sieltä automaattisimmasta päästä jakeluita.

oletko katsonut archin xorg wiki sivua? https://wiki.archlinux.org/index.php/Xorg

xf86-video-intel asennettuna.

[ 15.920==)] ( No screen section available. Using defaults. [ 15.920] (**) |-->Screen "Default Screen Section" (0)
[ 16.434] (II) VESA(0): Creating default Display subsection in Screen section "Default Screen Section" for depth/fbbpp 24/32
[ 16.484] (--) VESA(0): Virtual size is 1024x768 (pitch 1024) [ 16.484] (**) VESA(0): *Built-in mode "1024x768" [ 16.484] (**) VESA(0): *Built-in mode "800x600" [ 16.484] (**) VESA(0): Display dimensions: (370, 230) mm

Tuollaiset hyppäsi silmille log-tiedostosta. Voiko nuo default asetukset mitä tuo tyrkyttää olla 1024x768? Joku enemmän tietävä voi valaista. ???

Jostain syystä tuo käyttää edelleen VESA-ajuria, kuten tuolla lokissasi sanotaan. Varmaan pitäisi luoda xorg.conf jossa on määritelty Intelin ajuri käyttöön.
Voit siirtää sen xorg.confin takaisin ja muokata sitä jos haluat.

su - mv /etc/X11/xorg.conf_old /etc/X11/xorg.conf exit

Section "ServerLayout" Identifier "X.org Configured" Screen 0 "Screen0" 0 0 InputDevice "Mouse0" "CorePointer" InputDevice "Keyboard0" "CoreKeyboard" EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "dbe"
Load "dri"
Load "dri2"
Load "extmod"
Load "glx"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option “Protocol” "auto"
Option “Device” "/dev/input/mice"
Option “ZAxisMapping” "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section “Device”
### Available Driver options are:-
### Values: : integer, : float, : “True”/“False”,
### : “String”, : " Hz/kHz/MHz",
### : “%”
### [arg]: arg optional
#Option “ShadowFB” # []
#Option “DefaultRefresh” # []
#Option “ModeSetClearScreen” # []
Identifier "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
Monitor "Default Monitor"
DefaultDepth 24
SubSection "Display"
Modes “1440x900” “1280x800” "1024x768"
EndSubSection
EndSection

Mikä tässä nyt on? Ei toimi vieläkään. Huomauttakaa toki jos tuosta löytyy virheitä. Ensimmäistä kertaa joudun xorg.conffia muokkamaan (tässä tarkoituksessa), muissa käyttiksissä toiminut aina moitteetta :wink: