Raspbian, kiinteä ip wlan yhteydellä

Elikkäs ongelmana on saada Raspbianiin (Jessie, “server asennus”) kiinteä sisäverkon IP. Aiemmin asetukset olivat kunnossa tähän, mutta nyt kokeillessani linux.fi wikin mukaan tehtyjä /etc/network/interfaces sekä /etc/wpa_supplicant/wpa_supplicant.conf tiedostoja uuteen raspberryyn (vanha ei ole käytössä, joten ei ole kyse päällekkäisistä asetuksista), ei kiinteää IP:tä vaan tule (kuin satunnaisesti).

Olen lukenut tähän liittyen lukuisia raspi keskysteluja ja kokeillut muokata näissä mainittuja pieniä poikkeavuuksia itselleni, välillä IP olikin se asetettu, mutta taas seuraavalla käynnistyksellä ei…

Tällä hetkellä itselläni seuraavat asetukset käytössä…

/etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet static
	address 192.168.1.200
	netmask 255.255.255.0
	network 192.168.1.0
	broadcast 192.168.1.255
	gateway 192.168.1.1
#allow-hotplug wlan0
auto wlan0
iface wlan0 inet manual
	wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
	
	iface raspinet inet static
	address 192.168.1.200
	netmask 255.255.255.0
	network 192.168.1.0
	broadcast 192.168.1.255
	gateway 192.168.1.1

sekä

/etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
	ssid="Oma-SSID"
	proto=WPA RSN
	scan_ssid=1
	key_mgmt=WPA-PSK
	pairwise=CCMP TKIP
	group=CCMP TKIP
	psk="wlan-salasana"
	id_str="raspinet"
}

Nyt lähes joka kerta RasPi saa IP osoitteekseen 192.168.1.102. Mitä teen tässä väärin & miksi aiemmin toimineet asetukset eivät enää toimineetkaan Rasbian Jessiessä?

Edit: Vaihdettu toiselle alueelle, joskaan alueen kuvauksessa ei ole päätä eikä häntää :slight_smile:

En ymmärrä näistä mitään, mutta …

Oletko kokeillut laittaa eri IP:n eth0:lle ja wlan0:lle ?

/etc/network/interfaces
auto lo
iface lo inet loopback
iface eth0 inet static
	address 192.168.1.200
	netmask 255.255.255.0
	network 192.168.1.0
	broadcast 192.168.1.255
	gateway 192.168.1.1
#allow-hotplug wlan0
auto wlan0
iface wlan0 inet manual
	wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
	iface raspinet inet static
	address 192.168.1.201
	netmask 255.255.255.0
	network 192.168.1.0
	broadcast 192.168.1.255
	gateway 192.168.1.1

Debian Jessiessä on ymmärtääkseni jo systemd ja sillä, kuten muillakin systemd:tä käyttävillä jakeluilla käytetään systemd-networkd/etc/network/interfacesin sijaan.

En ole koskaan käyttänyt sitä muuten, kuin kiinteällä verkolla seuraavilla asetuksilla (/etc/systemd/network/eth0.network):

[Match]
Name=eth0

[Network]
Address=172.16.1.2/16
Gateway=172.16.0.1
# DNS has no effect unless systemd-resolved is used
# systemctl enable systemd-resolved && systemctl start systemd-resolved
# ln -sf /run/systemd/resolve/resolv.conf /etc/resolv.conf
DNS=127.0.0.1
DNS=::1
DNS=8.8.4.4
# Enable systemd-timesyncd with `timedatectl set-ntp true`
NTP=fi.pool.ntp.org

Asetusten säätämisen jälkeen systemctl enable systemd-networkd ja systemctl start systemd-networkd pitäisi toimia.

Sen sanotaan toimivan myös WLAN-verkoilla,

Arch Wikissä on aiheesta vähän:

Tämäkin voi olla ongelmana, kahdella koneella tai verkkokortilla ei voi olla sama IP.

En ole koittanut tuota (tai joskus aiemmin ensimmäisellä raspilla kokeilin, mutta muutin samaksi, kun ajattelin, että ei haittaisi siinä tapauksessa, jos/kun molemmat eivät ole kytkettynä samaan aikaan). Eli tarkoitus oli, että ssh:lla saisi yhteyden samasta ip:stä, riippumatta kumpaa yhteyttä käytti ja näin toimikin tuolloin… Ok, käytännössä kyseessä oli aina wlan ja nykyinen pi on a+ mallia, joten itseasiassa koko eth0 määrittelyhän on turha tuolla kun ethernet porttia ei ole, on vaan jäänteitä…

Ja jessiessä tosiaan systemd käytössä. En vain ole aiemmin edes pohtinut mihin kaikkeen se tulee vaikuttamaan, mutta järkeenkäypä asia, että siksi tuo on päivityksen jälkeen elänyt omaa elämäänsä tuon IP puolen suhteen. :smile:

Kiitos tähänastisista, kokeilen mennä tältä pohjalta eteenpäin! Raportoin tänne tuonnempana kuinka kävi.

Kolo seinässä syvenee ja patti päässä kasvaa… :smiley:

Yritin edetä tuon mukisesti, mutta eihän se ottanut tuulta alleen. Itselläni on wlan usb-palikka piiriin RTL8188CUS pohjautuva ja törmäsin vastaavaan ongelmaan kuin täällä:

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=104856

tuolla lopussa vielä vinkattu olevan vastaava kuin https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=104974

Eli noissa pidettiin ongelmana wpa_supplicantia (itsellänikin on juurikin versio 2.3 kuten tuolla mainittu. No kokeilin olla välittämättä niistä, tein tuon /etc/systemd/network/wlan0.network asetustiedoston + /etc/wpa_supplicant/example.conf tiedoston Arch wikin Configuration osan mukaisesti, jotta oikeat tiedot olisi valmiiksi tuolla (muutinpa nimeksikin vielä wpa_supplicant.conf). Lopuksi ajoin nuo systemctl enable systemd-networkd ja systemctl start systemd-networkd komennot sudona. Wlan ei herännyt eloon, ei edes uudelleenkäynnistyksen jälkeen…

Lopuksi kopioin takaisin /etc/interfaces tiedoston, sekä tuon mainitsemani version /etc/wpa_supplicant.conf tiedostosta. Muutin Interfaces osioon eth0 IP:n, käynnistin Pin ja…

Wlan herää henkiin, mutta IP ei todellakaan ole tuo staattinen. :smile:

Nyt IP näyttäisi olevan yhä tuo 192.168.1.102 (katsottu läpäriltä nmap komennolla)…

Edit:
Osui silmiin seuraava: https://lists.debian.org/debian-user/2015/04/msg01194.html

Yes, Debian Jessie still uses /etc/init.d/networking, which reads /etc/network/interfaces by default. (Even on systemd systems, that script is executed.)

Jatkanpa lukemista…